SetCrankRatio Method


Rebar Crank Type Utils Set Crank Ratio Method

Sets the crank ratio value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static void SetCrankRatio(
	Document document,
	ElementId rebarCrankTypeId,
	double crankRatio
)

Parameters

document Document
The document.
rebarCrankTypeId ElementId
The Rebar Crank Type id.
crankRatio Double
The crank ratio value.
Exceptions
Exception Condition
ArgumentException The rebarCrankTypeId doesn't represent a valid Rebar Crank Type. It should be an ElementType of BuiltInCategory.OST_RebarCrankType category.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The given value for crankRatio must be positive.
Remarks
The crank slope is 1/crankRatio.
See Also