HookAngleAtEnd Property


Rebar Shape Terminations Data Hook Angle At End Property

Identifies the hook angle (in degrees) at the end of the rebar shape. The angle must be at least 0 and no more than 180. In case it is 0 it will be considered that the shape doesn't have a hook. Common values are 0, 90, 135, and 180. Setting this property to a value strictly greater than 0 and less or almost equal with 180 will set the HasCrankAtEnd to false and EndTreatmentTypeIdAtEnd to ElementId.InvalidElementId.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public int HookAngleAtEnd { get; set; }

Property Value

Int32
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: hookAngleAtEnd must be at least 0 and no more than 180.
See Also