HookAngle1 Property


Rebar Bend Data Hook Angle 1 Property

The angle (in degrees) of the hook at the end. Must be at least 0 and no more than 180. If the value is 0 it means that there is no hook. The default value is 0. When setting from 0 to another value all crank lengths for end will be set to 0. When setting this value to 0 HookLength1 will be set to 0.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public int HookAngle1 { get; set; }

Property Value

Int32
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: hookAngle1 must be at least 0 and no more than 180.
See Also