SetCrankLengthMultiplier Method


Rebar Crank Type Utils Set Crank Length Multiplier Method

Sets the crank length multiplier value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public static void SetCrankLengthMultiplier(
	Document document,
	ElementId rebarCrankTypeId,
	double crankLengthMultiplier
)

Parameters

document Document
The document.
rebarCrankTypeId ElementId
The Rebar Crank Type id.
crankLengthMultiplier Double
The crank length multiplier value.
Exceptions
Exception Condition
ArgumentException The rebarCrankTypeId doesn't represent a valid Rebar Crank Type. It should be an ElementType of BuiltInCategory.OST_RebarCrankType category.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The given value for crankLengthMultiplier must be positive.
See Also