SetCrankRatioOverride Method


Rebar Set Crank Ratio Override Method

Sets the crank ratio at the indicated bar end as an override value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public void SetCrankRatioOverride(
	int end,
	double crankRatio
)

Parameters

end Int32
The bar end.
crankRatio Double
The crank ratio.
Exceptions
Exception Condition
ArgumentOutOfRangeException end must be 0 or 1.
InvalidOperationException The bar does not have a valid Rebar Crank Type at the end. -or- The ability to override crank lengths is not enabled for this rebar instance. Use enableCrankLengthOverride(true) to enable it.
Remarks
The crank slope is 1/crankRatio. When the crank ratio is set, the crank offset length is keeping the same value. The angled length and straight length are adjusted.
See Also