Intersect(Curve, CurveIntersectResultOption) Method


Curve Intersect(Curve, Curve Intersect Result Option) Method

Calculates the intersection of this curve with the specified curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public CurveIntersectResult Intersect(
	Curve curve,
	CurveIntersectResultOption option
)

Parameters

curve Curve
The specified curve to intersect with this curve.
option CurveIntersectResultOption
Specifies the amount of information to return in the CurveIntersectResult .

Return Value

CurveIntersectResult
The CurveIntersectResult describing the geometric relationship of the two curves. This will contain at least a SetComparisonResult and, if requested, a list of CurveOverlapPoint s specifying where the two curves overlap or intersect.
Exceptions
Exception Condition
ArgumentNullException The specified curve is .
InvalidOperationException Failed to calculate the intersection.
Remarks
The CurveIntersectResultOption passed to this method determines the amount of information that will be calculated and returned:
  • CurveIntersectResultOption.Simple - Calculate only the geometric relationship between the two curves, as indicated by a SetComparisonResult value.
  • CurveIntersectResultOption.Detailed - Calculate the geometric relationship between the two curves, along with any points or intervals of overlap. This option may result in additional computations being performed compared to CurveIntersectResultOption.Simple.
See Also