NumberOfBarPositions Property


Rebar Number Of Bar Positions Property

The number of potential bars in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public int NumberOfBarPositions { get; set; }

Property Value

Int32
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: the number of bar positions numberOfBarPositions is less than 1 or more than 1002.
InapplicableDataException When setting this property: This rebar element represents a single bar (the layout rule is Single). -or- When setting this property: The rebar set layout does not permit changing the number of bar positions.
Remarks
The number of positions is equal to the number of actual bars (the Quantity), plus the number of bars that are excluded. The number of bar positions can be set for a rebar set with layout rule FixedNumber or NumberWithSpacing.
See Also