GetHookRotationAngle Method


Rebar Shape Get Hook Rotation Angle Method

Note: This API is now obsolete.

Gets the termination's (e.g hook, crank) out of plane rotation angle at the specified end. The angle is used for both hook and crank.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use RebarShape.GetTerminationsData().TerminationRotationAngleAtStart or RebarShape.GetTerminationsData().TerminationRotationAngleAtEnd instead.")]
public double GetHookRotationAngle(
	int end
)

Parameters

end Int32
0 for the start, 1 for the end.

Return Value

Double
Returns the termination's (e.g hook, crank) out of plane rotation angle at the specified end. The angle is used for both hook and crank.
Exceptions
Exception Condition
ArgumentOutOfRangeException end must be 0 or 1.
See Also