GroundConductorSize Class


Ground Conductor Size Class

Note: This API is now obsolete.

Represents electrical ground conductor size definition information.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB.Electrical GroundConductorSize

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("GroundConductorSize is deprecated in Revit 2026 and will be removed in a future version of Revit. Please use ConductorSize instead. ConductorSizes will be created by GroundConductorSize properly during document upgrade.")]
public class GroundConductorSize : APIObject

The GroundConductorSize type exposes the following members.

Properties
Name Description
Public property Ampacity Get ampacity which is used for specifying size, the unit is ampere.
Public property ConductorSize Get conductor size corresponding to specific ampacity.
Public property MaterialBelongTo Get the material type which include this ground conductor size information.
Top
Methods
Name Description
Top
Remarks
Ground conductor size is defined based on corresponding wire material type.
See Also