GroundConductorSize Class


Ground Conductor Size Class

Note: This API is now obsolete.

Represents electrical ground conductor size definition information.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB.Electrical GroundConductorSize

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("GroundConductorSize is deprecated in Revit 2026 and will be removed in a future version of Revit. Please use ConductorSize instead. ConductorSizes will be created by GroundConductorSize properly during document upgrade.")]
public class GroundConductorSize : APIObject

The GroundConductorSize type exposes the following members.

Properties
Name Description
Public property Ampacity Get ampacity which is used for specifying size, the unit is ampere.
Public property ConductorSize Get conductor size corresponding to specific ampacity.
Public property IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property MaterialBelongTo Get the material type which include this ground conductor size information.
Top
Methods
Name Description
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
Ground conductor size is defined based on corresponding wire material type.
See Also