Analytical
|
Represents the data and parameters of analytical bus node.

System
Object
Autodesk.Revit.DB.Electrical AnalyticalDistributionNodePropertyData
Autodesk.Revit.DB.Electrical AnalyticalPowerDistributableNodeData
Autodesk.Revit.DB.Electrical AnalyticalBusData
Autodesk.Revit.DB.Electrical AnalyticalDistributionNodePropertyData
Autodesk.Revit.DB.Electrical AnalyticalPowerDistributableNodeData
Autodesk.Revit.DB.Electrical AnalyticalBusData
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

The AnalyticalBusData type exposes the following members.

Name | Description | |
---|---|---|
![]() |
AssignedPhasesNumber |
The number of electrical phases assigned through the distribution system of the power distributable node.
(Inherited from AnalyticalPowerDistributableNodeData ) |
![]() |
AssignedVoltage |
The voltage assigned through the distribution system of the power distributable node.
(Inherited from AnalyticalPowerDistributableNodeData ) |
![]() |
ConnectedPhases |
The electrical connected phases of the electrical analytical node to its upstream node.
(Inherited from AnalyticalDistributionNodePropertyData ) |
![]() |
CurrentRating | The current rating value of the analytical bus. |
![]() |
DistributionSystem |
The distribution system of the power distributable node.
(Inherited from AnalyticalPowerDistributableNodeData ) |
![]() |
IsValidObject |
Specifies whether the .NET object represents a valid Revit entity.
(Inherited from AnalyticalDistributionNodePropertyData ) |
![]() |
TotalConnectedCurrent | The total connected current of the analytical bus. |

Name | Description | |
---|---|---|
![]() |
Dispose |
(Inherited from AnalyticalDistributionNodePropertyData ) |
![]() |
Equals |
Determines whether the specified object is equal to the current object.
(Inherited from Object ) |
![]() |
GetAllAvailableConnectedPhasesOnDownstream |
Get all the available electrical connected phases that this power distributable node can provide to the downstream node.
(Inherited from AnalyticalPowerDistributableNodeData ) |
![]() |
GetApparentPerPhaseResults |
Get an ElectricalPerPhaseData which contains each electrical phase's apparent load and apprent current of the power distributable node.
(Inherited from AnalyticalPowerDistributableNodeData ) |
![]() |
GetConnectedPhasesOnDownstream |
Get the electrical connected phases of the downstream node.
(Inherited from AnalyticalPowerDistributableNodeData ) |
![]() |
GetDemandPerPhaseResults |
Get an ElectricalPerPhaseData which contains each electrical phase's demand load and demand current of the power distributable node.
(Inherited from AnalyticalPowerDistributableNodeData ) |
![]() |
GetHashCode |
Serves as the default hash function.
(Inherited from Object ) |
![]() |
GetType |
Gets the
Type
of the current instance.
(Inherited from Object ) |
![]() |
SetConnectedPhasesOnDownstream |
Set the electrical connected phases of the downstream node.
(Inherited from AnalyticalPowerDistributableNodeData ) |
![]() |
ToString |
Returns a string that represents the current object.
(Inherited from Object ) |