TemporaryViewModes Class


Temporary View Modes Class

A data structure containing data related to temporary view modes.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB TemporaryViewModes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class TemporaryViewModes : APIObject

The TemporaryViewModes type exposes the following members.

Properties
Name Description
Public property AcceleratedGraphicsMode The current state of the Accelerated Graphics mode in the associated view.
Public property CustomColor Custom color for the TemporaryViewProperties mode.
Public property CustomTitle Custom title for the TemporaryViewProperties mode.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property PreviewFamilyVisibility The current state of the PreviewFamilyVisibility mode in the associated view.
Public property Static member PreviewFamilyVisibilityDefaultOnState Controls the default state of the PreviewFamilyVisibility mode in all views.
Public property Static member PreviewFamilyVisibilityDefaultUncutState Controls the default type of the On state of the PreviewFamilyVisibility mode in cut-able views.
Public property RevealConstraints The current state of the RevealConstraints mode in the associated view.
Public property RevealHiddenElements The current state of the RevealHiddenElements mode in the associated view.
Public property WorksharingDisplay The current state of the WorksharingDisplay mode in the associated view.
Top
Methods
Name Description
Public method DeactivateAllModes Deactivates all temporary modes that are currently active.
Public method DeactivateMode Deactivates the given temporary mode.
Public method GetCaption A text caption to use for the given mode.
Public method IsCustomized Identifies if a custom temporary view mode is currently active. A custom mode is active if there is a non-empty string set for CustomTitle .
Public method IsModeActive Tests whether a given mode is currently active or not.
Public method IsModeAvailable Tests whether a temporary view mode is currently available in the associated view.
Public method IsModeEnabled Tests whether a temporary view mode is currently enabled in the associated view.
Public method IsValidState Tests whether the given state is valid for the associated view and the context the view is currently in.
Public method RemoveCustomization Removes all customized values for the TemporaryViewProperties mode.
Top
Remarks

The class contains methods and properties to manipulate states of various temporary view modes that may or may not be avilable in any of visible views of a Revit document. The temporary modes are enumerated in the TemporaryViewMode class.

Every view that supports temporary view modes owns an instance of this TemporaryViewModes class, which can be obtained by accessing the TemporaryViewModes property of the View class. Note that views which do not support temporary modes will have that property's value be Null.

Multiple temporary view modes can coexist. Also, TemporaryViewProperties mode can be customized to display custom title and custom color. Setting custom title and color affects only TemporaryViewProperties mode for the specific view.

See Also