HookOrient1 Property


Rebar Bend Data Hook Orient 1 Property

Note: This API is now obsolete.

Identifies the orientation of the termination (e.g. hook, crank) at the end. The default value is RebarTerminationOrientation::Left.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This property is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use RebarBendData.TerminationOrientation1 instead.")]
public RebarHookOrientation HookOrient1 { get; set; }

Property Value

RebarHookOrientation
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also