DoesBarExistAtPosition Method


Rebar Does Bar Exist At Position Method

Checks whether a bar is included at the specified position.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public bool DoesBarExistAtPosition(
	int barPosition
)

Parameters

barPosition Int32
A bar position index between 0 and NumberOfBarPositions-1.

Return Value

Boolean
Returns true if the bar at the specified position is included, false otherwise.
Exceptions
Exception Condition
ArgumentOutOfRangeException barPosition should be in range [ 0, NumberOfBarPositions-1 ] and the bar at barPosition should be included.
See Also