Ellipse Class |
A whole or partial ellipse.

System
Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB GeometryObject
Autodesk.Revit.DB Curve
Autodesk.Revit.DB Ellipse
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB GeometryObject
Autodesk.Revit.DB Curve
Autodesk.Revit.DB Ellipse
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

The Ellipse type exposes the following members.

Name | Description | |
---|---|---|
![]() |
ApproximateLength |
The approximate length of the curve.
(Inherited from Curve ) |
![]() |
Center | Returns the center of the ellipse. |
![]() |
GraphicsStyleId |
The ElementId of the GeometryObject's GraphicsStyle
(Inherited from GeometryObject ) |
![]() |
Id |
A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
(Inherited from GeometryObject ) |
![]() |
IsBound |
Describes whether the parameter of the curve is restricted to a particular interval.
(Inherited from Curve ) |
![]() |
IsClosed |
Describes whether the curve is closed.
(Inherited from Curve ) |
![]() |
IsCyclic |
The boolean value that indicates whether this curve is cyclic.
(Inherited from Curve ) |
![]() |
IsElementGeometry |
Indicates whether this geometry is obtained directly from an Element.
(Inherited from GeometryObject ) |
![]() |
IsReadOnly |
Identifies if the object is read-only or modifiable.
(Inherited from APIObject ) |
![]() |
Length |
The exact length of the curve.
(Inherited from Curve ) |
![]() |
Normal | Returns the normal to the plane in which the ellipse is defined. |
![]() |
Period |
The period of this curve.
(Inherited from Curve ) |
![]() |
RadiusX | Returns the X vector radius of the ellipse. |
![]() |
RadiusY | Returns the Y vector radius of the ellipse. |
![]() |
Reference |
Returns a stable reference to the curve.
(Inherited from Curve ) |
![]() |
Visibility |
The visibility.
(Inherited from GeometryObject ) |
![]() |
XDirection | The X direction. |
![]() |
YDirection | The Y direction. |

Name | Description | |
---|---|---|
![]() |
Clone |
Returns a copy of this curve.
(Inherited from Curve ) |
![]() |
ComputeClosestPoints |
(Inherited from Curve ) |
![]() |
ComputeDerivatives |
Returns the vectors describing the curve at the specified parameter.
(Inherited from Curve ) |
![]() |
ComputeNormalizedParameter |
Computes the normalized curve parameter from the raw parameter.
(Inherited from Curve ) |
![]() |
ComputeRawParameter |
Computes the raw parameter from the normalized parameter.
(Inherited from Curve ) |
![]() ![]() |
CreateCurve | Creates a new geometric ellipse or elliptical arc object. |
![]() |
CreateOffset |
Creates a new curve that is an offset of the existing curve.
(Inherited from Curve ) |
![]() |
CreateReversed |
Creates a new curve with the opposite orientation of the existing curve.
(Inherited from Curve ) |
![]() |
CreateTransformed |
Crates a new instance of a curve as a transformation of this curve.
(Inherited from Curve ) |
![]() |
Dispose |
Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject ) |
![]() |
Distance |
Returns the shortest distance from the specified point to this curve.
(Inherited from Curve ) |
![]() |
Equals |
Determines whether the specified
Object
is equal to the current
Object
.
(Inherited from GeometryObject ) |
![]() |
Evaluate |
Evaluates and returns the point that matches a parameter along the curve.
(Inherited from Curve ) |
![]() |
GetEndParameter |
Returns the raw parameter value at the start or end of this curve.
(Inherited from Curve ) |
![]() |
GetEndPoint |
Returns the 3D point at the start or end of this curve.
(Inherited from Curve ) |
![]() |
GetEndPointReference |
Returns a stable reference to the start point or the end point of the curve.
(Inherited from Curve ) |
![]() |
GetHashCode |
Gets the integer value of the geometry object as hash code
(Inherited from GeometryObject ) |
![]() |
GetType |
Gets the
Type
of the current instance.
(Inherited from Object ) |
![]() |
Intersect(Curve) |
Obsolete.
Calculates the intersection of this curve with the specified curve. (Inherited from Curve ) |
![]() |
Intersect(Curve, CurveIntersectResultOption) |
Calculates the intersection of this curve with the specified curve.
(Inherited from Curve ) |
![]() |
Intersect(Curve, IntersectionResultArray ) |
Obsolete.
Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve ) |
![]() |
IsInside(Double) |
Indicates whether the specified parameter value is within this curve's bounds.
(Inherited from Curve ) |
![]() |
IsInside(Double, Int32 ) |
Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.
(Inherited from Curve ) |
![]() |
MakeBound |
Changes the bounds of this curve to the specified values.
(Inherited from Curve ) |
![]() |
MakeUnbound |
Makes this curve unbound.
(Inherited from Curve ) |
![]() |
Project |
Projects the specified point on this curve.
(Inherited from Curve ) |
![]() |
SetGraphicsStyleId |
Sets the graphics style id for this curve.
(Inherited from Curve ) |
![]() |
Tessellate |
Valid only if the curve is bound. Returns a polyline approximation to the curve.
(Inherited from Curve ) |
![]() |
ToString |
Returns a string that represents the current object.
(Inherited from Object ) |