Ellipse Class |
A whole or partial ellipse.

System
Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB GeometryObject
Autodesk.Revit.DB Curve
Autodesk.Revit.DB Ellipse
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB GeometryObject
Autodesk.Revit.DB Curve
Autodesk.Revit.DB Ellipse
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

The Ellipse type exposes the following members.

Name | Description | |
---|---|---|
![]() |
![]() |
Id |
![]() |
IsBound |
![]() |
IsClosed |
![]() |
IsCyclic |
![]() |
IsElementGeometry |
![]() |
IsReadOnly |
![]() |
Length |
![]() |
![]() |
RadiusX | Returns the X vector radius of the ellipse. |
![]() |
![]() |
Visibility |
![]() |
XDirection | The X direction. |
![]() |
YDirection | The Y direction. |

Name | Description | |
---|---|---|
![]() |
ComputeDerivatives |
![]() |
ComputeNormalizedParameter |
![]() |
ComputeRawParameter |
![]() ![]() |
![]() |
CreateReversed |
![]() |
CreateTransformed |
![]() |
Dispose |
![]() |
Distance |
![]() |
Equals |
Determines whether the specified
Object
is equal to the current
![]() |
Evaluate |
![]() |
GetEndParameter |
![]() |
GetEndPoint |
![]() |
GetEndPointReference |
![]() |
GetHashCode |
![]() |
GetType |
Gets the
![]() |
Intersect(Curve) |
![]() |
Intersect(Curve, CurveIntersectResultOption) |
![]() |
Intersect(Curve, IntersectionResultArray ) |
![]() |
IsInside(Double) |
![]() |
IsInside(Double, Int32 ) |
![]() |
MakeBound |
![]() |
MakeUnbound |
![]() |
Project |
![]() |
SetGraphicsStyleId |
![]() |
Tessellate |
![]() |
ToString |