NurbSpline Class


Nurb Spline Class

A nurb spline.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class NurbSpline : Curve

The NurbSpline type exposes the following members.

Properties
Name Description
Public property CtrlPoints Returns the control points of the nurb spline.
Public property Degree Returns the degree of the nurb spline.
Public property isRational Returns whether the nurb spline is rational or not.
Public property Knots Return/set the knots of the nurb spline.
Public property Weights Returns the weights of the nurb spline.
Top
Methods
Name Description
Public method Static member Create Creates a new geometric NurbSpline object from a HermiteSpline.
Public method Static member CreateCurve(HermiteSpline) Creates a new geometric Curve object by converting the given HermiteSpline. The created curve may be a NURBSpline or a simpler curve such as line or arc.
Public method Static member CreateCurve(IList XYZ , IList Double )
Public method Static member CreateCurve(Int32, IList Double , IList XYZ )
Public method Static member CreateCurve(Int32, IList Double , IList XYZ , IList Double )
Public method SetControlPointsAndWeights
Top
Remarks
The nurb spline lies in the plane defined by control point, weight,knots,degree.
See Also