FabricArea Class


Fabric Area Class

An object that represents an Fabric Area Distribution within the Autodesk Revit project. It is container for Fabric Sheet elements.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB Element
Autodesk.Revit.DB.Structure FabricArea

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class FabricArea : Element

The FabricArea type exposes the following members.

Properties
Name Description
Public property CoverOffset The additional cover offset of the fabric distribution.
Public property Direction The Major Direction of the Fabric Area.
Public property DirectionOrigin The Origin Point of the Major Direction of the Fabric Area.
Public property DistributionOfWiresAtCover The distribution of wires that is closest to the cover.
Public property FabricAreaType The type of the Fabric Area.
Public property FabricLocation The Fabric location in the host.
Public property FabricSheetTypeId The id of the Fabric Sheet Type for this element.
Public property HostId The id of the Host element for the fabric area.
Public property LapSplicePosition The fabric lap splice position in the fabric distribution.
Public property MajorLapSpliceLength The fabric lap splice length in the fabric distribution in the major direction.
Public property MajorSheetAlignment The fabric sheet alignment in the fabric distribution in the major direction.
Public property MinorLapSpliceLength The fabric lap splice length in the fabric distribution in the minor direction.
Public property MinorSheetAlignment The fabric sheet alignment in the fabric distribution in the minor direction.
Public property SketchId The id of the Sketch element for this element.
Public property TagViewId The element of the view in which to tag new members of this element.
Top
Methods
Name Description
Public method CopyCurveLoopsInSketch Creates copies of the CurveLoops in the FabricArea sketch.
Public method Static member Create(Document, Element, XYZ, ElementId, ElementId) Creates a FabricArea based on a host boundary.
Public method Static member Create(Document, Element, IList CurveLoop , XYZ, XYZ, ElementId, ElementId)
Public method GetBoundaryCurveIds Retrieves the identifiers of the set of curves forming the boundary of the Fabric Area.
Public method GetFabricSheetElementIds Retrieves the identifiers of all the FabricSheet Elements in the FabricArea.
Public method GetReinforcementRoundingManager Returns an object for managing reinforcement rounding override settings.
Public method GetTotalSheetMass Calculates the total sheet mass: Volume of Wire * Unit Weight.
Public method GetValidViewsForTags Gets ids of the views where tags and symbols can be placed for the FabricArea and/or FabricSheets
Public method IsCoverOffsetValid Identifies if the specified value is valid for use as a cover offset.
Public method IsValidMajorLapSplice Identifies if the specified value is valid for use as a major lap splice.
Public method IsValidMinorLapSplice Identifies if the specified value is valid for use as a minor lap splice.
Public method Static member RemoveFabricReinforcementSystem Deletes the specified FabricArea, and converts its FabricSheet elements to equivalent Single Fabric Sheet elements.
Top
Remarks
This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Fabric Area element is available only in the Autodesk Revit Structure product.
See Also