Fabrication
|
Represents a fabrication component in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

The FabricationPart type exposes the following members.

Name | Description | |
---|---|---|
![]() |
Alias | The alias of the fabrication part. |
![]() |
AssemblyInstanceId |
The id of the assembly instance to which the element belongs.
(Inherited from Element ) |
![]() |
BottomOfPartElevation | The associated elevation to the bottom of fabrication part off of the current level. |
![]() |
BoundingBox |
Retrieves a box that circumscribes all geometry of the element.
(Inherited from Element ) |
![]() |
Category |
Retrieves a Category object that represents the category or sub category in which the
element resides.
(Inherited from Element ) |
![]() |
CenterlineLength | The centerline length of the fabrication part. |
![]() |
ConnectorManager | The connector manager of the fabrication part. |
![]() |
CreatedPhaseId |
Id of a Phase at which the Element was created.
(Inherited from Element ) |
![]() |
CutType | The cut type of the fabrication part. |
![]() |
DemolishedPhaseId |
Id of a Phase at which the Element was demolished.
(Inherited from Element ) |
![]() |
DesignOption |
Returns the design option to which the element belongs.
(Inherited from Element ) |
![]() |
Document |
Returns the Document in which the Element resides.
(Inherited from Element ) |
![]() |
DomainType | The domain type for the fabrication part. |
![]() |
DoubleWallMaterial | The double wall material identifier of the fabrication part. |
![]() |
DoubleWallMaterialArea | The double wall material area of the fabrication part. If the fabrication part is not double walled, returns zero. |
![]() |
DoubleWallMaterialThickness | The double wall material thickness of the fabrication part. If the fabrication part is not double walled, returns zero. |
![]() |
FreeSize | The inner size of the fabrication part. |
![]() |
Geometry |
Retrieves the geometric representation of the element.
(Inherited from Element ) |
![]() |
GeometryChecksum | Gets the geometry checksum of the fabrication part symbol, and it does nothing with the fabrication part instance position. |
![]() |
GroupId |
The id of the group to which an element belongs.
(Inherited from Element ) |
![]() |
HangerRodKit | Specifies whether an ancillary kit is being used to override support rods, bolts and clips, if any. A value of 0 indicates no override is being used. |
![]() |
HasDoubleWall | True if the fabrication part is double walled. |
![]() |
HasInsulation | True if the fabrication part is insulated. |
![]() |
HasLining | True if the fabrication part is lined. |
![]() |
Id |
A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element ) |
![]() |
InsulationArea | The insulation area of the fabrication part. If the fabrication part is not insulated, returns zero. |
![]() |
InsulationSpecification | The fabrication part insulation specification identifier. |
![]() |
InsulationThickness | The insulation thickness of the fabrication part. If the fabrication part is not insulated, returns zero. |
![]() |
InsulationType | The insulation type of the fabrication part. |
![]() |
IsBoughtOut | True if the fabrication part is bought out. |
![]() |
IsModifiable |
Identifies if the element is modifiable.
(Inherited from Element ) |
![]() |
IsTransient |
Indicates whether an element is transient or permanent.
(Inherited from Element ) |
![]() |
IsValidObject |
Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element ) |
![]() |
ItemCustomId | The item custom identifier for the fabrication part. |
![]() |
ItemNumber | The item number that is used for identification, re-ordering from shop. |
![]() |
LevelId |
The id of the level associated with the element.
(Inherited from Element ) |
![]() |
LevelOffset | The associated level offset that indicates the distance from the center of the fabrication part to the current level. |
![]() |
LiningArea | The lining area of the fabrication part. If the fabrication part is not lined, returns zero. |
![]() |
LiningThickness | The lining thickness of the fabrication part. If the fabrication part is not lined, returns zero. |
![]() |
LiningType | The lining type of the fabrication part. |
![]() |
Location |
This property is used to find the physical location of an element within a project.
(Inherited from Element ) |
![]() |
Material | The fabrication material identifier. |
![]() |
MaterialGauge | The fabrication material gauge identifier. |
![]() |
MaterialThickness | The material thickness of the fabrication part. |
![]() |
Name |
A human readable name for the Element.
(Inherited from Element ) |
![]() |
Notes | The notes of the fabrication part. |
![]() |
Origin | The origin of the fabrication part element. |
![]() |
OverallSize | The overall size of the fabrication part. |
![]() |
OwnerViewId |
The id of the view that owns the element.
(Inherited from Element ) |
![]() |
Parameter BuiltInParameter |
Retrieves a parameter from the element given a parameter id.
(Inherited from Element ) |
![]() |
Parameter Definition |
Retrieves a parameter from the element based on its definition.
(Inherited from Element ) |
![]() |
Parameter Guid |
Retrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element ) |
![]() |
Parameters |
Retrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element ) |
![]() |
ParametersMap |
Retrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element ) |
![]() |
PartGuid | The fabrication part's globally unique identifier. |
![]() |
PartStatus | The status identifier for the fabrication part. |
![]() |
Pinned |
Identifies if the element has been pinned to prevent changes.
(Inherited from Element ) |
![]() |
ProductCode | The current database id of the part within the fabrication database. |
![]() |
ProductDataRange | The product data range of the fabrication part. |
![]() |
ProductFinishDescription | The product finish description of the fabrication part. |
![]() |
ProductInstallType | The product install type of the fabrication part. |
![]() |
ProductListEntry | The product entry index of the fabrication part. A value of -1 indicates the fabrication part is not a product list. |
![]() |
ProductLongDescription | The product long description of the fabrication part. |
![]() |
ProductMaterialDescription | The product material description of the fabrication part. |
![]() |
ProductName | The product name of the fabrication part. |
![]() |
ProductOriginalEquipmentManufacture | The product original equipment manufacture (OEM) of the fabrication part. |
![]() |
ProductShortDescription | The product short description of the fabrication part. |
![]() |
ProductSizeDescription | The product size description of the fabrication part. |
![]() |
ProductSpecificationDescription | The product specification description of the fabrication part. |
![]() |
ServiceAbbreviation | The associated service abbreviation for the fabrication service. |
![]() |
ServiceId | The fabrication part service identifier. The service can only be changed to compatible services. |
![]() |
ServiceName | The name of the service associated with the fabrication part. |
![]() |
ServiceType | The service type identifier of the fabrication part. |
![]() |
SheetMetalArea | The sheet metal area of the fabrication part. |
![]() |
Size | The size of the fabrication part. |
![]() |
Slope | The slope for the straight fabrication part. |
![]() |
Specification | The fabrication part specification identifier. |
![]() |
SpoolName | The spool name of the fabrication part. |
![]() |
TopOfPartElevation | The associated elevation to the top of fabrication part off of the current level. |
![]() |
UniqueId |
A stable unique identifier for an element within the document.
(Inherited from Element ) |
![]() |
ValidationStatus | The validation status of the fabrication part. |
![]() |
Vendor | The vendor of the fabrication part. |
![]() |
VendorCode | The vendor code of the fabrication part. |
![]() |
VersionGuid |
Get the element version Guid.
(Inherited from Element ) |
![]() |
ViewSpecific |
Identifies if the element is owned by a view.
(Inherited from Element ) |
![]() |
Weight | The weight of the fabrication part. |
![]() |
WorksetId |
Get Id of the Workset which owns the element.
(Inherited from Element ) |

Name | Description | |
---|---|---|
![]() |
AddPartCustomData | Add custom data type to the fabrication part. The new data gets the default value defined by the fabrication configuration. |
![]() |
AdjustEndLength | Adjusts the length for the specified connector. |
![]() ![]() |
AlignPartByConnector | Align the part by its connector to a point and rotation in free space. |
![]() ![]() |
AlignPartByConnectors | Moves fabrication part by one of its connectors and aligns it to another connector. |
![]() ![]() |
AlignPartByConnectorToConnector | Align a part by its connector to another connector. This will replace the FabricationPart::AlignPartByConnectors method. |
![]() ![]() |
AlignPartByInsertionPoint | Align the part by its insertion point to a point and rotation in free space. |
![]() ![]() |
AlignPartByInsertionPointAndCutInToStraight | Align the part by its insertion point to a point and rotation on a straight. This will automatically size and connect the part being cut into, if possible. |
![]() |
ArePhasesModifiable |
Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element ) |
![]() |
CanAdjustEndLength | Checks if the end of fabrication part can be adjusted. |
![]() |
CanASlopeBeApplied | This will test if a slope can be applied to the part and maintain connections with any connected parts. |
![]() |
CanBeHidden |
Indicates if the element can be hidden in the view.
(Inherited from Element ) |
![]() |
CanBeLocked |
Identifies if the element can be locked.
(Inherited from Element ) |
![]() |
CanDeleteSubelement |
Checks if given subelement can be removed from the element.
(Inherited from Element ) |
![]() |
CanFlipPart | Validates if the fabrication part is one of the supported fabrication part types that can be flipped. |
![]() |
CanHaveTypeAssigned |
Identifies if the element can have a type assigned.
(Inherited from Element ) |
![]() |
CanSplitStraight | Validates if the straight can be split into two at the passed in point. |
![]() |
ChangeTypeId(ElementId) |
Changes the type of the element.
(Inherited from Element ) |
![]() ![]() |
ConnectAndCouple | Makes a connection between the specified connectors and adds coupling if necessary. |
![]() ![]() |
Create(Document, FabricationItemFile, ElementId) | Creates a fabrication part element from a fabrication item file. |
![]() ![]() |
Create(Document, FabricationServiceButton, Int32, ElementId) | Creates a fabrication part element based on button. |
![]() ![]() |
Create(Document, FabricationServiceButton, Double, Double, ElementId) | Creates a fabrication part element based on button and size. |
![]() ![]() |
CreateHanger(Document, FabricationServiceButton, Int32, ElementId) | Creates a free placed hanger. |
![]() ![]() |
CreateHanger(Document, FabricationServiceButton, ElementId, Connector, Double, Boolean) | Creates a hanger on the fabrication part. |
![]() ![]() |
CreateHanger(Document, FabricationServiceButton, Int32, ElementId, Connector, Double, Boolean) | Creates a hanger on the fabrication part. |
![]() |
DeleteEntity |
Deletes the existing entity created by %schema% in the element
(Inherited from Element ) |
![]() |
DeleteSubelement |
Removes a subelement from the element.
(Inherited from Element ) |
![]() |
DeleteSubelements |
(Inherited from Element ) |
![]() |
Dispose |
(Inherited from Element ) |
![]() |
Equals |
Determines whether the specified object is equal to the current object.
(Inherited from Object ) |
![]() |
EvaluateAllParameterValues |
Evaluates all the parameters' values of the element.
(Inherited from Element ) |
![]() |
EvaluateParameterValues |
(Inherited from Element ) |
![]() |
Flip | Flips the fabrication part that is directionally oriented (tees, crosses, valves, dampers, etc.) to the opposite direction. |
![]() |
GetAllFabricationBodyConnectorDefinitions | Gets all connectors that are valid to be assigned to the part for a specified body connector |
![]() |
GetAllFabricationDoubleWallConnectorDefinitions | Gets all connectors that are valid to be assigned to the part for a specified double wall connector |
![]() |
GetCalculatedDimensionValue | Gets the calculated dimension value. |
![]() |
GetDependentElements |
Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element ) |
![]() |
GetDimensionCalculatedOptions | Gets the calculated options of the fabrication dimension. |
![]() |
GetDimensions | Gets all fabrication dimensions. |
![]() |
GetDimensionValue | Gets the value of the fabrication dimension, returns value in Revit internal units. |
![]() |
GetEntity |
Returns the existing entity corresponding to the Schema if it has been saved in the
Element, or an invalid entity otherwise.
(Inherited from Element ) |
![]() |
GetEntitySchemaGuids |
Returns the Schema guids of any Entities stored in this element.
(Inherited from Element ) |
![]() |
GetExternalFileReference |
Gets information pertaining to the external file referenced
by the element.
(Inherited from Element ) |
![]() |
GetExternalResourceReference |
Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element ) |
![]() |
GetExternalResourceReferenceExpanded |
Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element ) |
![]() |
GetExternalResourceReferences |
Gets the map of the external resource references referenced
by the element.
(Inherited from Element ) |
![]() |
GetExternalResourceReferencesExpanded |
Gets the expanded map of the external resource references referenced
by the element.
(Inherited from Element ) |
![]() |
GetGeneratingElementIds |
Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element ) |
![]() |
GetGeometryObjectFromReference |
Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element ) |
![]() |
GetHashCode |
Serves as the default hash function.
(Inherited from Object ) |
![]() |
GetHostedInfo | Gets the fabrication hosted element information. |
![]() |
GetInsulationLiningGeometry | Gets insulation and lining geometry for this fabrication part. |
![]() |
GetMaterialArea |
Gets the area of the material with the given id.
(Inherited from Element ) |
![]() |
GetMaterialIds |
Gets the element ids of all materials present in the element.
(Inherited from Element ) |
![]() |
GetMaterialVolume |
Gets the volume of the material with the given id.
(Inherited from Element ) |
![]() |
GetMonitoredLinkElementIds |
Provides the link instance IDs when the element is monitoring.
(Inherited from Element ) |
![]() |
GetMonitoredLocalElementIds |
Provides the local element IDs when the element is monitoring.
(Inherited from Element ) |
![]() |
GetOrderedParameters |
Gets the parameters associated to the element in order.
(Inherited from Element ) |
![]() |
GetParameter |
Retrieves a parameter from the element given identifier.
(Inherited from Element ) |
![]() |
GetParameterFormatOptions |
Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element ) |
![]() |
GetParameters |
Retrieves the parameters from the element via the given name.
(Inherited from Element ) |
![]() |
GetPartAncillaryUsage | Gets a list of all ancillary usage information for the part. |
![]() |
GetPartCustomDataInteger | Get custom data integer value for the specified custom data. |
![]() |
GetPartCustomDataReal | Get custom data real value for the specified custom data. |
![]() |
GetPartCustomDataText | Get custom data text for the specified custom data. |
![]() |
GetPhaseStatus |
Gets the status of a given element in the input phase
(Inherited from Element ) |
![]() |
GetProductListEntryCount | Gets the number of product entries for this part. |
![]() |
GetProductListEntryName | Gets the specified product list entry name. |
![]() |
GetRodInfo | Gets the fabrication rod information. |
![]() |
GetSubelements |
Returns the collection of element subelements.
(Inherited from Element ) |
![]() |
GetTransform | Gets the transformation matrix of the fabrication part element. |
![]() |
GetType |
Gets the
Type
of the current instance.
(Inherited from Object ) |
![]() |
GetTypeId |
Returns the identifier of this element's type.
(Inherited from Element ) |
![]() |
GetValidTypes |
Obtains a set of types that are valid for this element.
(Inherited from Element ) |
![]() |
GetVersionHistory | Gets a history of version change information about the current part. |
![]() |
HasCustomData | Check if fabrication part contains custom data already. |
![]() |
HasNoConnections | Checks to see if all the fabrication part's connectors are open. |
![]() |
HasPhases |
Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element ) |
![]() |
IsAHanger | Checks whether it is a hanger. |
![]() |
IsAStraight | Checks whether it is a straight part. |
![]() |
IsATap | Checks if it is any sort of tap. |
![]() |
IsCreatedPhaseOrderValid |
Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element ) |
![]() |
IsDemolishedPhaseOrderValid |
Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element ) |
![]() |
IsDimensionCalculated | Checks if the fabrication dimension is calculated. |
![]() |
IsExternalFileReference |
Determines whether this Element represents an external
file.
(Inherited from Element ) |
![]() |
IsHidden |
Identifies if the element has been permanently hidden in the view.
(Inherited from Element ) |
![]() |
IsMonitoringLinkElement |
Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element ) |
![]() |
IsMonitoringLocalElement |
Indicate whether an element is monitoring other local elements.
(Inherited from Element ) |
![]() |
IsPhaseCreatedValid |
Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element ) |
![]() |
IsPhaseDemolishedValid |
Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element ) |
![]() |
IsProductList | Gets whether or not the fabrication part is a product list. |
![]() |
IsProductListEntryCompatibleSize | Checks to see if this part can be changed to the specified product entry without altering any connected dimensions. |
![]() |
IsSameAs | |
![]() |
IsValidType(ElementId) |
Checks if given type is valid for this element.
(Inherited from Element ) |
![]() |
LookupParameter |
Attempts to find a parameter on the element which has the given name.
(Inherited from Element ) |
![]() ![]() |
OptimizeLengths | |
![]() ![]() |
PlaceAsTap | Places the part by its connector to a specific position on the straight part at the specified distance from the host part connector. |
![]() ![]() |
PlaceFittingAsCutIn | Places the fitting on the straight part by cut in, use the fitting's focal point as the insertion position. |
![]() |
RefersToExternalResourceReference |
Determines whether this Element uses external resources associated with
a specified external resource type.
(Inherited from Element ) |
![]() |
RefersToExternalResourceReferences |
Determines whether this Element uses external resources.
(Inherited from Element ) |
![]() |
RemovePartCustomData | Remove custom data from the fabrication part. |
![]() ![]() |
Reposition | Repositions the fabrication straight part to another end of the run. |
![]() ![]() |
RotateConnectedPartByConnector | Rotates a connected fabrication part around the axis of the specified connector. |
![]() ![]() |
RotateConnectedTap | Rotates a connected fabrication tap by the specified angles about the primary and secondary axis. |
![]() ![]() |
SaveAsFabricationJob | |
![]() |
SetCalculatedDimensionValue | Sets the calculated dimension value. |
![]() |
SetDimensionValue | Sets the fabrication dimension value. The value is in Revit internal units. |
![]() |
SetEntity |
Stores the entity in the element. If an Entity described by the same Schema already
exists, it is overwritten.
(Inherited from Element ) |
![]() |
SetPartCustomDataInteger | Set the custom data integer value for the specified custom data. |
![]() |
SetPartCustomDataReal | Set the custom data real value for the specified custom data. |
![]() |
SetPartCustomDataText | Set the custom data real value for the specified custom data. |
![]() |
SetPositionByEnd | Positions the connector of the fabrication part element by the passed point. |
![]() |
SplitStraight(XYZ) | Splits the straight into two at the passed in point. |
![]() |
SplitStraight(Document, ElementId, XYZ) | Splits the straight into two at the passed in point. |
![]() ![]() |
StretchAndFit | |
![]() |
ToString |
Returns a string that represents the current object.
(Inherited from Object ) |